1

Onderwerp: probleem met installaties

Beste mensen,

Ik wordt een beetje gek. Elke keer als ik iets probeer te installeren kom ik dit tegen:

freebsd# make all install
===>   php4-ffmpeg-0.5.0 depends on executable in : phpize - found
===>   php4-ffmpeg-0.5.0 depends on file: /usr/local/bin/autoconf259 - found
===>   php4-ffmpeg-0.5.0 depends on shared library: avcodec.1 - not found
===>    Verifying install for avcodec.1 in /usr/ports/multimedia/ffmpeg
===>  Building for ffmpeg-0.4.9.p1_6
gmake: Nothing to be done for `all'.
gmake LDFLAGS="-L/usr/ports/multimedia/ffmpeg/work/ffmpeg-0.4.9-pre1/libavcodec -L/usr/ports/multimedia/ffmpeg/work/ffmpeg-0.4.9-pre1/libavcodec/libpostproc  -L/usr/local/lib -L/usr/X11R6/lib  -g " -C libavcodec all
gmake[1]: Entering directory `/usr/ports/multimedia/ffmpeg/work/ffmpeg-0.4.9-pre1/libavcodec'
gmake[1]: Nothing to be done for `all'.
gmake[1]: Leaving directory `/usr/ports/multimedia/ffmpeg/work/ffmpeg-0.4.9-pre1/libavcodec'
gmake LDFLAGS="-L/usr/ports/multimedia/ffmpeg/work/ffmpeg-0.4.9-pre1/libavcodec -L/usr/ports/multimedia/ffmpeg/work/ffmpeg-0.4.9-pre1/libavcodec/libpostproc  -L/usr/local/lib -L/usr/X11R6/lib  -g " -C libavformat all
gmake[1]: Entering directory `/usr/ports/multimedia/ffmpeg/work/ffmpeg-0.4.9-pre1/libavformat'
cc -O3 -Wall -fPIC -DPIC -I/usr/local/include  -I/usr/X11R6/include  -fomit-frame-pointer -fno-unit-at-a-time -I.. -I/usr/ports/multimedia/ffmpeg/work/ffmpeg-0.4.9-pre1 -I/usr/ports/multimedia/ffmpeg/work/ffmpeg-0.4.9-pre1/libavcodec -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -c -o udp.o udp.c
udp.c:25:24: arpa/inet.h: No such file or directory
udp.c:29:19: netdb.h: No such file or directory
gmake[1]: *** [udp.o] Error 1
gmake[1]: Leaving directory `/usr/ports/multimedia/ffmpeg/work/ffmpeg-0.4.9-pre1/libavformat'
gmake: *** [lib] Error 2
*** Error code 2

Stop in /usr/ports/multimedia/ffmpeg.
*** Error code 1

Stop in /usr/ports/graphics/php4-ffmpeg.

Ik heb een FreeBSD 6.0 systeem

Laptop: Ubuntu 6.x en WinXP prof
Speeldoos: FreeBSD 6.0
Workstation FreeBSD 6.0 & WinVista
Server1 FreeBSD 6.0

Re: probleem met installaties

Probeer een recentere cvs checkout van je ports tree te doen. stuur anders een meeltje naar de verantwoordelijke mensen (maintainer, mailinglijst).

"Hack for yourself, hack for your interest, hack to learn." | #nedbsd@irc.afternet.org

Re: probleem met installaties

Zijn de standaard header files wel geinstalleerd? Bestaat /usr/include/netdb.h bijvoorbeeld?

Re: probleem met installaties

Ik heb een checout gedaan, ik heb alle gcc versies geprobeerd. Maar niks wil helpen. Packages installeren lukt, maar bij ports niet.

Hoe installerd ik standaard header files?? Is daar een package of port voor?

Laptop: Ubuntu 6.x en WinXP prof
Speeldoos: FreeBSD 6.0
Workstation FreeBSD 6.0 & WinVista
Server1 FreeBSD 6.0

Re: probleem met installaties

Opgelost.

De headerfiles zaten niet op hun plek.
Ik heb ze in /usr/include/lwres/netdb.h en /usr/local/include/postgresql/server/utils/inet.h gevonden.

Daarna heb ik
/usr/local/include/postgresql/server/utils/inet.h in /usr/include/arpa/ GEKOPIEERD
en
/usr/include/lwres/netdb.h in /usr/include/ GEKOPIEERD.

Het werkt. Is dit trouwens de juiste oplossing voor dit soort gevallen? Of heb je een efficientere oplossing?

Laptop: Ubuntu 6.x en WinXP prof
Speeldoos: FreeBSD 6.0
Workstation FreeBSD 6.0 & WinVista
Server1 FreeBSD 6.0

6

Re: probleem met installaties

Ik ben niet echt thuis in de BSD-wereld, maar ik denk, dat het plaatsen van een link (i.p.v. kopieren) voldoende geweest was.

Jan.

Enthousiast Pardus-gebruiker.

Re: probleem met installaties

Als dit om een vers en clean systeem gaat, dan is de php4-ffmpeg-0.5.0 port gewoon broken.

"Hack for yourself, hack for your interest, hack to learn." | #nedbsd@irc.afternet.org