1

Onderwerp: Roundcube opzetten op VPS

Ik wil graag Roundcube op mijn eigen VPS. De installatie lukt me wel, maar de juiste configuratie niet.
Wanneer ik de applicatie heb geínstalleerd, ga ik naar de website waarop ik Roundcube wil draaien - mailbox.mijndomein.nl/installer.
Daar gaat bijna alles vlekkeloos.
Welke gegevens moet/kan ik daar invullen bij de IMAP-config en SMTP-config?

Test SMTP config

Server: smtp.google.com
Port: 25
User:
Password:

Sender:
Recipient:

Test IMAP config

Server   
Port    143
Username   
Password   

(wellicht zijn de poortnummers niet correct, want poort 25 zal wel geblokkeerd zijn)

Wie helpt mij?

Re: Roundcube opzetten op VPS

je zal een mailserver (postfix bijv.) moeten opzetten en dan al de mails (helaas) relayen naar Google. https://www.linode.com/docs/email/postf … tp-debian7 . Verder mag ik hopen dat die VPS boer gewoon port 25 open zet. Als moet ik toegeven dat ik dat inmiddels ook niet meer doe en per poort een mail/request wil hebben.

ACAB: All computers are broken. https://medium.com/message/everything-i … e5f33a24e1 "I've decided that you need gray hair and hemorrhoids to be a consultant.
The gray hair makes you look distinguished & the hemorrhoids make you look concerned."

Re: Roundcube opzetten op VPS

Dit lijkt me beter te werken:

IMAP server: imap.gmail.com
Beveiligingstype: SSL (altijd)
Poort: 993

SMTP-server: smtp.gmail.com
Beveiligingstype: SSL (altijd)
Poort: 465

Denk er wel aan dat je in je gmail accountinstellingen gebruik van imap aan zet.

Re: Roundcube opzetten op VPS

Sillynder, dankjewel voor je reactie.
Inmiddels is het gedeelte van de SMTP-config gelukt.
De IMAP-config lukt me niet. Daar staat nu ingevuld:
Server: ssl://imap.google.com
Port    993
Username    (hier staat mijn Gmail-adres ingevuld dat ook bij SMTP is gebruikt, enkele regels daarboven)
Password    (idem; staat onder het Gmail-adres bij SMTP-server)

Als ik op "check login" klik, krijg ik de foutmelding:
NOT OK(Login failed for ***** (mijn Gmail-adres) from 11.22.33.44. Could not connect to ssl://imap.google.com:993: php_network_getaddresses: getaddrinfo failed: Name or service not known)

Wat doe ik hier fout?

Vriendelijke groet,
Guido van Harten

5 Laatst bewerkt door Sillynder (30 Dec 2015 20:48:03)

Re: Roundcube opzetten op VPS

"Name or service not known" en "ssl://.."

Kan het zijn dat je "ssl" vóór imap.google.com hebt staan? *knip* (onjuiste informatie)

Re: Roundcube opzetten op VPS

Sillynder schreef:

Kan het zijn dat je "ssl" vóór imap.google.com hebt staan? Dat is i.i.g. niet juist. SSL zul je ergens als optie moeten meegeven.

Ben je daar zeker van?
Op de pagina waar ik dit moet invullen, staat nl.:
Leave blank to show a textbox at login. To use SSL/IMAPS connection, type ssl://hostname

Vriendelijke groet,
Guido van Harten

Re: Roundcube opzetten op VPS

Ssl weglaten... door de poortaanduiding komt het goed.

Re: Roundcube opzetten op VPS

Zojuist even Roundcube gëinstalleerd en aldus de documentatie moet er inderdaad wel ssl voor:

Test SMTP config

Server: ssl://smtp.gmail.com
Port: 465
User: *****@gmail.com
Password: ************

Trying to send email...
SMTP send:  OK

Ik ga even verder testen :-)

Re: Roundcube opzetten op VPS

En nu IMAP:

Test IMAP config

Server   
Port    993
Username   
*****@gmail.com
Password    *****
Connecting to ssl://imap.gmail.com...
IMAP connect:  OK(SORT capability: no)

Zou dus moeten werken met ssl://imap.gmail.com en poort 993.

Re: Roundcube opzetten op VPS

Ik kan nu vanuit de webinterface verzendenen ontvangen.

Dit is m'n config.inc.php:

<?php

/* Local configuration for Roundcube Webmail */

// ----------------------------------
// SQL DATABASE
// ----------------------------------
// Database connection string (DSN) for read+write operations
// Format (compatible with PEAR MDB2): db_provider://user:password@host/database
// Currently supported db_providers: mysql, pgsql, sqlite, mssql or sqlsrv
// For examples see http://pear.php.net/manual/en/package.d … ro-dsn.php
// NOTE: for SQLite use absolute path: 'sqlite:////full/path/to/sqlite.db?mode=0646'
$config['db_dsnw'] = 'mysql://roundcube:roundcube@localhost/roundcube';

// ----------------------------------
// IMAP
// ----------------------------------
// The mail host chosen to perform the log-in.
// Leave blank to show a textbox at login, give a list of hosts
// to display a pulldown menu or set one host as string.
// To use SSL/TLS connection, enter hostname with prefix ssl:// or tls://
// Supported replacement variables:
// %n - hostname ($_SERVER['SERVER_NAME'])
// %t - hostname without the first part
// %d - domain (http hostname $_SERVER['HTTP_HOST'] without the first part)
// %s - domain name after the '@' from e-mail address provided at login screen
// For example %n = mail.domain.tld, %t = domain.tld
// WARNING: After hostname change update of mail_host column in users table is
//          required to match old user data records with the new host.
$config['default_host'] = 'ssl://imap.gmail.com';

// TCP port used for IMAP connections
$config['default_port'] = 993;

// ----------------------------------
// SMTP
// ----------------------------------
// SMTP server host (for sending mails).
// To use SSL/TLS connection, enter hostname with prefix ssl:// or tls://
// If left blank, the PHP mail() function is used
// Supported replacement variables:
// %h - user's IMAP hostname
// %n - hostname ($_SERVER['SERVER_NAME'])
// %t - hostname without the first part
// %d - domain (http hostname $_SERVER['HTTP_HOST'] without the first part)
// %z - IMAP domain (IMAP hostname without the first part)
// For example %n = mail.domain.tld, %t = domain.tld
$config['smtp_server'] = 'ssl://smtp.gmail.com';

// SMTP port (default is 25; use 587 for STARTTLS or 465 for the
// deprecated SSL over SMTP (aka SMTPS))
$config['smtp_port'] = 465;

// SMTP username (if required) if you use %u as the username Roundcube
// will use the current username for login
$config['smtp_user'] = '*****@gmail.com';

// SMTP password (if required) if you use %p as the password Roundcube
// will use the current user's password for login
$config['smtp_pass'] = '*****';

// provide an URL where a user can get support for this Roundcube installation
// PLEASE DO NOT LINK TO THE ROUNDCUBE.NET WEBSITE HERE!
$config['support_url'] = '';

// this key is used to encrypt the users imap password which is stored
// in the session record (and the client cookie if remember password is enabled).
// please provide a string of exactly 24 chars.
$config['des_key'] = '67c31a72xvxvxvxvxvx014d1d11';

// Automatically add this domain to user names for login
// Only for IMAP servers that require full e-mail addresses for login
// Specify an array with 'host' => 'domain' values to support multiple hosts
// Supported replacement variables:
// %h - user's IMAP hostname
// %n - hostname ($_SERVER['SERVER_NAME'])
// %t - hostname without the first part
// %d - domain (http hostname $_SERVER['HTTP_HOST'] without the first part)
// %z - IMAP domain (IMAP hostname without the first part)
// For example %n = mail.domain.tld, %t = domain.tld
$config['username_domain'] = '*****@gmail.com';

// ----------------------------------
// PLUGINS
// ----------------------------------
// List of active plugins (in plugins/ directory)
$config['plugins'] = array();

Wat me wel opviel tijdens het configureren is dat een instelling aanpassen niet altijd even lekker werkt. Ik heb meerdere keren config.inc.php verwijderd om opnieuw het configuratieproces te kunnen starten. Misschien ook even proberen?

Re: Roundcube opzetten op VPS

Sillynder schreef:

Zou dus moeten werken met ssl://imap.gmail.com en poort 993.

Inmiddels heb ik dit zelf kunnen oplossen.
Bij Server moest ik invullen:
ssl://imap.google.com:993

Sillynder schreef:

Wat me wel opviel tijdens het configureren is dat een instelling aanpassen niet altijd even lekker werkt. Ik heb meerdere keren config.inc.php verwijderd om opnieuw het configuratieproces te kunnen starten. Misschien ook even proberen?

Je hoeft config.inc.php niet te verwijderen. Als je de installer opnieuw start, krijg je nl. te zien dat (en zeg ik het uit het hoofd) je een regel aan config.inc.php kunt toevoegen om de installer weer draaiende te krijgen. Let op: deze regel dien je wel ONDERAAN toe te voegen.

Vriendelijke groet,
Guido van Harten

Re: Roundcube opzetten op VPS

Kijk, top.... de volhouder wint!

Re: Roundcube opzetten op VPS

Mooi dat het gelukt is!

...dat (en zeg ik het uit het hoofd) je een regel aan config.inc.php kunt toevoegen om de installer weer draaiende te krijgen...

Dat werkte bij mij niet; met of zonder regel onderaan startte het installatiegedeelte niet meer op.

Als je iets ander moest invullen dan ik vermoed ik bijna dat je een andere versie gebruikt dan ik. Ik heb versie 1.1.4 geïnstalleerd, waarin ik de poort en het serveradres apart moet invullen.

Re: Roundcube opzetten op VPS

Sillynder schreef:

Dat werkte bij mij niet; met of zonder regel onderaan startte het installatiegedeelte niet meer op.

Als je iets ander moest invullen dan ik vermoed ik bijna dat je een andere versie gebruikt dan ik. Ik heb versie 1.1.4 geïnstalleerd, waarin ik de poort en het serveradres apart moet invullen.

Nee, ik heb 1.1.4 geïnstalleerd. Maar als je eenmaal de config.inc.php hebt aangemaakt, dan zouden de diverse handleidingen en fora je ook verder moeten kunnen helpen om het bestand handmatig aan te passen.

Vriendelijke groet,
Guido van Harten