1

Onderwerp: VPS - upgraden - software installeren

Bij mijn provider heb ik een VPS waarop als nieuwste Ubuntu-versie momenteel Ubuntu 14.10 x64 draait. Omdat men in een overgangsfase zit naar een platform, komen daar nu geen nieuwe templates bij. Men adviseert mij om zelf handmatig te upgraden, maar dit lukt niet helemaal.
Na

#do-release-upgrade

heb ik Ubuntu 15.04.
Nog een keer

#do-release-upgrade

werkt niet, want dan krijg ik de foutmelding

An upgrade from 'vivid' to 'xenial' is not supported with this tool.

Toen besloot ik toch maar de software te gaan installeren. De voorbereidingen daartoe mislukten echter. Als ik de volgende opdrachten geef,

#sudo apt-get update
#sudo apt-get upgrade
#sudo apt-get dist-upgrade
#sudo apt-get install python-software-properties
#sudo add-apt-repository ppa:ondrej/php
#sudo apt-get update
#sudo apt-get install -y php5.6 php5.6-gd php5.6-curl php5.6-zip php5.6-dom php5.6-xml php5.6-simplexml php5.6-mbstring apache2 libapache2-mod-php5.6 mysql-server php5.6-mysql

krijg ik de melding

Couldn't find any package by regex 'php5.6'

Als ik de VPS afsluit en opnieuw start, krijg ik de melding Ubuntu 16.04.3 LTS beschikbaar is, maar

#do-release-upgrade

geeft ook als melding

An upgrade from 'vivid' to 'xenial' is not supported with this tool.

Hoe kan ik alsnog php installeren, op welke Ubuntu-release dan ook?

Vriendelijke groet,
Guido

Re: VPS - upgraden - software installeren

Zowel Ubuntu 14.10 als 15.04 worden niet meer ondersteund. Kan je er geen 16.04.3 op zetten?
https://www.ubuntu.com/download/server

Re: VPS - upgraden - software installeren

Ik heb 14.04 LTS geïnstalleerd.
Als ik daarop

#do-release-upgrade

geef,
krijg ik wel 16.04 LTS.
Probleem is dus opgelost.

Vriendelijke groet,
Guido