1

Onderwerp: raar default gateway probleempje

hallo allemaal

ik heb op men server het volgende in /etc/network/interface staan

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
    auto eth0
    iface eth0 inet dhcp
#    address 192.168.167.28
#    netmask 255.255.255.0
#    gatewau 192.168.167.1


    auto eth1
    iface eth1 inet dhcp
#    address 192.168.178.23
#    netmask 255.255.255.0
#    gateway 192.168.178.1

    auto eth2
    iface eth2 inet static
        address 10.0.254.254
        netmask 255.255.0.0

# ipv6
iface eth0 inet6 auto

iface eth1 inet6 auto

iface eth2 inet6 auto


# static routes
up route add default gw 192.168.178.1 metric 0
up route add default gw 192.168.167.1 metric 1

up route add -net 212.54.0.0 netmask 255.255.0.0 gw 192.168.178.1
down route del -net 212.54.0.0 netmask 255.255.0.0 gw 192.168.178.1

up route add -net 194.109.0.0 netmask 255.255.0.0 gw 192.168.167.1
down route del -net 194.109.0.0 netmask 255.255.0.0 gw 192.168.167.1

de bedoeling is dat ik 2 defalt gateways kan gebruiken
egter als ik type route krijg ik het volgende te zien

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.167.1   0.0.0.0         UG    0      0        0 eth0
default         192.168.167.1   0.0.0.0         UG    0      0        0 eth0
default         192.168.167.1   0.0.0.0         UG    1      0        0 eth0
10.0.0.0        *               255.255.0.0     U     0      0        0 eth2
192.168.167.0   *               255.255.255.0   U     0      0        0 eth0
192.168.167.1   *               255.255.255.255 UH    0      0        0 eth0
192.168.178.0   *               255.255.255.0   U     0      0        0 eth1
192.168.178.1   *               255.255.255.255 UH    0      0        0 eth1
194.109.0.0     192.168.167.1   255.255.0.0     UG    0      0        0 eth0
212.54.0.0      192.168.178.1   255.255.0.0     UG    0      0        0 eth1

zo als jullie zien heb ik 3 default gateway's echter alle 3 de keer de gateway van men xs4all modem
terwijl hij ook de ziggo moet gebruiken
ziggo hangt aan interface eth1 de gateway is 192.168.178.1
en xs4all hangt aan eth0 en is gateway 192.168.167.1
wie kan me zegen wat ik fout doe
overigens is het locale netwerk eth2 ip addres interface 10.0.254.254 met netmask 255.255.0.0

sorie voor de schrijffouten maar ik heb deceleksie.

ik gebruik debian linux met kernel 2.6.686

2 Laatst bewerkt door 5Tgff##2699Jbv!!rrOn (02 Jan 2015 20:58:00)

Re: raar default gateway probleempje

Hoe moet jouw pc weten via welke 'default gateway' een ip-pakje verstuurt moet worden? Dat zul jij hem via route commando's moeten vertellen... anders gaat alles via eth0 (prim interface).

Je moet dus moeten aangeven voor welke adressen/reeksen de routes anders moeten gaan.

p.s. je kunt maar 1 default gateway hebben.... dat is de laatste fallback-rule namelijk. De rest zijn routes.

Re: raar default gateway probleempje

je kan wel mer defalt gateway's hebben volgens beetje zoeken op google.
egter stond in de network interface alles wel goed.
maar in shorewall zaten paar klijne configuratie foutjes.
en nu werkt het dus allemaal wel goed.
tog bedankt voor de info

groeten: peter

sorie voor de schrijffouten maar ik heb deceleksie.

ik gebruik debian linux met kernel 2.6.686

4 Laatst bewerkt door bigred (04 Jan 2015 06:40:02)

Re: raar default gateway probleempje

Ik weet niet of je de config file over getypt hebt of een copy hebt gemaakt:
gatewau 192.168.167.1

Dat moet gateway zijn niet gatewau

Standaard kun je inderdaad geen 2 default gateways hebben, probeer eens met traceroute over welke verbinding je nu naar buiten gaat en of dit wisselt per sessie.

Re: raar default gateway probleempje

bigred ik had hem ge copjeerd en ge plakt.
die regel stond dus inderdaad fout.
en dan te bedenken dat ik er wel 10x over heen had ge keken.
hoe ik slegtzien HI wink

sorie voor de schrijffouten maar ik heb deceleksie.

ik gebruik debian linux met kernel 2.6.686

6 Laatst bewerkt door maarten_wolf (05 Jan 2015 16:20:46)

Re: raar default gateway probleempje

peugeot2 schreef:

Hoe moet jouw pc weten via welke 'default gateway' een ip-pakje verstuurt moet worden? Dat zul jij hem via route commando's moeten vertellen... anders gaat alles via eth0 (prim interface).

Je moet dus moeten aangeven voor welke adressen/reeksen de routes anders moeten gaan.

p.s. je kunt maar 1 default gateway hebben.... dat is de laatste fallback-rule namelijk. De rest zijn routes.

Dit is niet helemaal waar.

Een default gateway heeft een prio. Is iets via default gateway 0 niet bereikbaar dan word de andere gateway automatisch geprobeerd. Prio word bepaald door volgorde van toevoegen. Gateway die als eerste erin gezet is heeft de hoogste prio.

Verdeling van verkeer werkt echter niet. Je PC zal altijd via dezelfde gateway naar buiten gaan.
Omgekeerd werkt het wel. Je bent wel via beide gateway's bereikbaar voor de apparaten in die beide netwerken.

D e b i a n

Re: raar default gateway probleempje

maarten_wol jauwn verhaal klopt in zeeeeeer grote lijnnen.
egter als shorewall doet routen en hij allebij de interface's kent bepaald hij wel degelik zelf wat naar buiten gaat via welke gateway.
zonder dat je routing tabels aan maakt.
zo stuurd hij zonder regels ing via xs4all verbinding.
maar msn via ziggo.
en volgens mij word dit geregeld door de funksie: Load-balance verkeer

sorie voor de schrijffouten maar ik heb deceleksie.

ik gebruik debian linux met kernel 2.6.686

Re: raar default gateway probleempje

Was best handig geweest in de eerste posting dat je shorewall als load balancer gebruikt (antwoord op mijn allereerste vraag) ;-). Verder is er een verschil tussen een gateway en een default gateway.

Re: raar default gateway probleempje

was inderdaad handig ge weest.
stond er toen niet bij stil dat shorewall het probleem kon veroorzaken.

en gateways en defaltgateways dat die verschilend zijn snap ik ook nog wel.
default is meestal als de r geen andere voorwardes zijn .

sorie voor de schrijffouten maar ik heb deceleksie.

ik gebruik debian linux met kernel 2.6.686