1

Onderwerp: error bij yum update en installaties linux

Hoi, ik hoop dat ik op de goeie plek ben voor mijn probleem. Op mijn vps Linux 6.8 heb ik sinds enkele dagen een probleem. Kan haast niets meer installeren en ook yum update lukt niet ik krijg dit:

[root@vmi66617 ~]# yum update
Loaded plugins: fastestmirror, security
Setting up Update Process
Loading mirror speeds from cached hostfile
* atomic: www4.atomicorp.com
* base: ftp.fau.de
Excluding mirror: mirror.de.leaseweb.net
Excluding mirror: mirror.nl.leaseweb.net
* epel: ftp.fau.de
* extras: ftp.fau.de
* remi-safe: mirror.23media.de
* updates: ftp.fau.de
Resolving Dependencies
--> Running transaction check
---> Package mysql.x86_64 0:5.5.50-34.el6.art will be obsoleted
---> Package mysql-bench.x86_64 0:5.5.50-34.el6.art will be obsoleted
---> Package mysql-community-bench.x86_64 0:5.6.32-2.el7 will be obsoleting
---> Package mysql-community-client.x86_64 0:5.6.32-2.el7 will be obsoleting
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: mysql-community-client-5.6.32-2.el7.x86_64
---> Package mysql-community-devel.x86_64 0:5.6.32-2.el7 will be obsoleting
---> Package mysql-community-libs.x86_64 0:5.6.32-2.el7 will be obsoleting
--> Processing Dependency: mysql-community-common(x86-64) >= 5.6.10 for package: mysql-community-libs-5.6.32-2.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: mysql-community-libs-5.6.32-2.el7.x86_64
---> Package mysql-community-server.x86_64 0:5.6.32-2.el7 will be obsoleting
--> Processing Dependency: systemd for package: mysql-community-server-5.6.32-2.el7.x86_64
--> Processing Dependency: systemd for package: mysql-community-server-5.6.32-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: mysql-community-server-5.6.32-2.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: mysql-community-server-5.6.32-2.el7.x86_64
---> Package mysql-connector-odbc.x86_64 0:5.1.5r1144-7.el6 will be updated
---> Package mysql-connector-odbc.x86_64 0:5.3.6-1.el7 will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: mysql-connector-odbc-5.3.6-1.el7.x86_64
---> Package mysql-devel.x86_64 0:5.5.50-34.el6.art will be obsoleted
---> Package mysql-libs.x86_64 0:5.5.50-34.el6.art will be obsoleted
---> Package mysql-server.x86_64 0:5.5.50-34.el6.art will be obsoleted
--> Running transaction check
---> Package mysql-community-client.x86_64 0:5.6.32-2.el7 will be obsoleting
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: mysql-community-client-5.6.32-2.el7.x86_64
---> Package mysql-community-common.x86_64 0:5.6.32-2.el7 will be installed
---> Package mysql-community-libs.x86_64 0:5.6.32-2.el7 will be obsoleting
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: mysql-community-libs-5.6.32-2.el7.x86_64
---> Package mysql-community-server.x86_64 0:5.6.32-2.el7 will be obsoleting
--> Processing Dependency: systemd for package: mysql-community-server-5.6.32-2.el7.x86_64
--> Processing Dependency: systemd for package: mysql-community-server-5.6.32-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: mysql-community-server-5.6.32-2.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: mysql-community-server-5.6.32-2.el7.x86_64
---> Package mysql-connector-odbc.x86_64 0:5.3.6-1.el7 will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: mysql-connector-odbc-5.3.6-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: mysql-connector-odbc-5.3.6-1.el7.x86_64 (mysql-connectors-community)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: mysql-community-client-5.6.32-2.el7.x86_64 (mysql56-community)
Requires: libc.so.6(GLIBC_2.17)(64bit)
Error: Package: mysql-community-server-5.6.32-2.el7.x86_64 (mysql56-community)
Requires: libc.so.6(GLIBC_2.17)(64bit)
Error: Package: mysql-community-server-5.6.32-2.el7.x86_64 (mysql56-community)
Requires: systemd
Error: Package: mysql-community-server-5.6.32-2.el7.x86_64 (mysql56-community)
Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
Error: Package: mysql-community-libs-5.6.32-2.el7.x86_64 (mysql56-community)
Requires: libc.so.6(GLIBC_2.17)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@vmi66617 ~]#

We zoeken al 2 dagen maar vinden niets dat het kan oplossen. Hopelijk dat iemand hier me kan helpen.

Groetjes, Herman.

Re: error bij yum update en installaties linux

Vanuit welke repository is mysql geïnstalleerd? Maak je gebruik van de officiële Mysql Yum Repository?

http://dev.mysql.com/downloads/repo/yum/

Bijvoorbeeld mysql-connector-odbc kom ik namelijk niet tegen op ftp.fau.de.