1

Onderwerp: gnome15

hallo allemaal
ik heb een Logitech g19 toetsenbord.
deze is verbonden met men pc waarop ik ubuntu 17 64 bit draai.
nu lees ik overal dat voor mijn toetsenbord ik gnome15 moet installeren.
echter heb ik hiermee een probleem
als eerste word gezegd dat ik de zooi moet downloaden met git clone https://github.com/Huskynarr/gnome15.git
en vervolgens naar de map moet gaan waar de zooi is neer gezet.
dit lukt nog wel
echter dan komt de stap dat ik zou moeten type ./configure.
en daar komt het probleem waar ik op vast loop meteen.
want ik krijg als response terug dat ./configure niet bestaat.
waardoor ik dus ook niet verder kan met de installatie.
als ik in de map kijk waar de software naar ge download is zie ik ./configure er ook niet bij staan.
graag hoor ik wat ik fout doe of waar ik wel werkende software kan downloaden.
het mag van mij ook ene ander programma zijn dan gnome15 als ik er maar men toetsenbord mee kan aan sturen zo als de extra knoppen, het ligt van men toetsenbord en het display.
dit mogen ook wat mij betreft verschillende propgramaas zijn.

hopelijk kan en wil iemand mij her mee verder helpen
groeten: peter

sorie voor de schrijffouten maar ik heb deceleksie.

ik gebruik debian linux met kernel 2.6.686

Re: gnome15

Ik vraag me af of dit gaat werken. Degene die het online heeft gezet zegt dat deze code niet onderhouden wordt sinds 2013. De originele repository is al sinds 2014 onbeschikbaar. Ubuntu pakketten zijn niet meer beschikbaar sinds Ubuntu 12.10.

Heb je trouwens wel eerst make, git en build-essential geïnstalleerd?

https://gnome15.org/downloads/manual-install/

Ubuntu levert volgens mij nog steeds pakketten voor de Logitech G15/G19?

https://packages.ubuntu.com/artful/g15stats

Kun je pakketten vinden met "g15" in de naam via Synaptic, Package Center of apt?

Re: gnome15

sillynder als eerste bedankt voor uw reactie.

ik heb beide linkt bekeken de eerste link heb ik bewust nog eens ge probeer de boel aan de gang te krijgen volgens de uitleg.
helaas ./configure blijft ontbreken.
verder heb ik ge keken of ik wat kon vinden met aptitude en ja daar staan nog wel g15 dingen.
echter bij installatie krijg ik van g15deamon error waaronder dat hij niet ge configureert kan worden.
deze werkt helaas dus ook niet goed.
mocht iemand mee willen kijken/puzzelen dan is dit mogelijk en kan ik indien gewenst via een pm altijd een teamviewer id en wachtwoord door geven.
hopelijk op een oplossing om het toch werkende te krijgen.

overigens zit ik nu even iets heel geks te bedenken.
in hoe veren heeft wine een goede usb ondersteuning en koppeling met links?
en indien dit vrij goed is in hoeverre zou de logitech windows software in wine werken?

sorie voor de schrijffouten maar ik heb deceleksie.

ik gebruik debian linux met kernel 2.6.686

Re: gnome15

Wine zou ik vanaf zien. Ik denk ook niet dat dat gaat werken, omdat voor toegang tot apparaten toch echt een linux kernel module noodzakelijk is.

Wat voor foutmelding krijg je precies van de g15daemon?

Re: gnome15

sillynder ik denk dat ik gek word.
want naar dat ik het nu dus op nieuw heb ge installeerde om de foutmelding te zien heeft hij alles zonder fout meldingen ge installerend.
nu uit vogelen hoe alles werkt want als ik bv g15stats uit voer krijg ik nog wel meldingen als: Sorry, cant connect to the G15daemon
dus vermoedelijk moet ik ergens nog wel iets configureren of mis ik nog wel iets.
gelukkig kom ik wel met uw hulp steeds een stapje verder.

sorie voor de schrijffouten maar ik heb deceleksie.

ik gebruik debian linux met kernel 2.6.686

6 Laatst bewerkt door Sillynder (04 Mar 2018 16:59:48)

Re: gnome15

Als er geen verbinding met de daemon gemaakt kan worden is mijn eerste gedachte of deze wel draait. Dat kun je controleren met

ps aux | grep g15

Als deze niet draait, dan zou je deze moeten kunnen starten via systemctl. Ik zou even in /etc/init.d kijken hoe deze precies heet. Dat zou gewoon g15daemon kunnen zijn en dan start je deze als volgt:

sudo systemctl start g15daemon

En de status van de daemon opvragen:

sudo systemctl status g15daemon

Re: gnome15

dakje helaas kan ik nu even niet kijken omdat de pc onder windows is op ge start om wat bestanden van men externe hd te kopjeren naar men /data (ext3) partitie.
dit duurt ongeveer 3 uur zodra dat gedaan is zal ik weer boten onder linux en dan kijk ik gelijk even.
ik had wel al ge keken /etc/default/g15deamon want soms staat daar een 0 die in een 1 veranderd moet worden of van false naar true om aan te geven dat hij mag starten.
daar stond wel iets in maar nix over of hij wel of niet mag starten.
ook had ik al ge probeert /etc/init.d/g15deamon start maar dat leverde eigenlijk niet egt verbetering.
ik zal straks dus even weer proberen en ook eventuele output in dit topic patsen

sorie voor de schrijffouten maar ik heb deceleksie.

ik gebruik debian linux met kernel 2.6.686

Re: gnome15

zo nu weer onder linux
ps aux | grep g15 geeft als reactie terug:

peter@jenp-0303181000:~$ ps aux | grep g15
peter     2420  0.0  0.0  14364  1068 pts/0    S+   21:46   0:00 grep --color=auto g15

dit geeft hij zowel als root als ook als gewone gebruiker
en: sudo systemctl start g15daemon geeft als reactie

peter@jenp-0303181000:~$ sudo systemctl start g15daemon
Job for g15daemon.service failed because the control process exited with error code.
See "systemctl  status g15daemon.service" and "journalctl  -xe" for details.

en als laatste geeft sudo systemctl status g15daemon als reactie

peter@jenp-0303181000:~$ sudo systemctl status g15daemon
● g15daemon.service - LSB: load deamon for Logitech G15 keyboard lcd display
   Loaded: loaded (/etc/init.d/g15daemon; generated; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sun 2018-03-04 21:50:14 CET; 1min 30
     Docs: man:systemd-sysv-generator(8)
  Process: 2634 ExecStart=/etc/init.d/g15daemon start (code=exited, status=1/FAI

mrt 04 21:50:11 jenp-0303181000 systemd[1]: Starting LSB: load deamon for Logite
mrt 04 21:50:14 jenp-0303181000 g15daemon[2666]: Unable to attach to the G15 Key
mrt 04 21:50:14 jenp-0303181000 g15daemon[2634]: Starting g15daemon: .../dev/inp
mrt 04 21:50:14 jenp-0303181000 systemd[1]: g15daemon.service: Control process e
mrt 04 21:50:14 jenp-0303181000 systemd[1]: Failed to start LSB: load deamon for
mrt 04 21:50:14 jenp-0303181000 systemd[1]: g15daemon.service: Unit entered fail
mrt 04 21:50:14 jenp-0303181000 systemd[1]: g15daemon.service: Failed with resul
...skipping...
● g15daemon.service - LSB: load deamon for Logitech G15 keyboard lcd display
   Loaded: loaded (/etc/init.d/g15daemon; generated; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sun 2018-03-04 21:50:14 CET; 1min 30
     Docs: man:systemd-sysv-generator(8)
  Process: 2634 ExecStart=/etc/init.d/g15daemon start (code=exited, status=1/FAI

mrt 04 21:50:11 jenp-0303181000 systemd[1]: Starting LSB: load deamon for Logite
mrt 04 21:50:14 jenp-0303181000 g15daemon[2666]: Unable to attach to the G15 Key
mrt 04 21:50:14 jenp-0303181000 g15daemon[2634]: Starting g15daemon: .../dev/inp
mrt 04 21:50:14 jenp-0303181000 systemd[1]: g15daemon.service: Control process e
mrt 04 21:50:14 jenp-0303181000 systemd[1]: Failed to start LSB: load deamon for
mrt 04 21:50:14 jenp-0303181000 systemd[1]: g15daemon.service: Unit entered fail
mrt 04 21:50:14 jenp-0303181000 systemd[1]: g15daemon.service: Failed with resul
~

hopelijk kan iemand er uit halen wat er fout zit
groeten: peter

sorie voor de schrijffouten maar ik heb deceleksie.

ik gebruik debian linux met kernel 2.6.686

Re: gnome15

De daemon zoekt naar /dev/input/uinput en die bestaat niet. Elders heb ik gelezen dat mensen dit in /etc/init.d/g15daemon aanpassen naar /dev/uinput. Daarmee gaat voor sommigen de foutmelding weg, maar daarmee werkt het toetsenbord nog niet. Je mist namelijk de benodigde device drivers en die worden door anderen gecompileerd, zoals je zelf ook al geprobeerd hebt.

Je zou het nog even kunnen proberen met de python3 / gtk branche van dit project:

https://github.com/guidugli/gnome15/tree/python3_gtk3

Flinke uitdaging wel.

Re: gnome15

helaas en toen waren we dus weer bij gnome15 en die mist ./configure

sorie voor de schrijffouten maar ik heb deceleksie.

ik gebruik debian linux met kernel 2.6.686

Re: gnome15

ik ben toch een heel klein stapje verder.
heb namelijk ge vonden dat je eerst automake moet uit voeren al vorens ./configure beschikbaar is.
en tja automake geeft vervolgens weer een hele berg errors zal hieronder de autput van automake neer zetten

configure.ac: error: no proper invocation of AM_INIT_AUTOMAKE was found.
configure.ac: You should verify that configure.ac invokes AM_INIT_AUTOMAKE,
configure.ac: that aclocal.m4 is present in the top-level directory,
configure.ac: and that aclocal.m4 was recently regenerated (using aclocal)
configure.ac:9: error: required file './config.guess' not found
configure.ac:9:   'automake --add-missing' can install 'config.guess'
configure.ac:9: error: required file './config.sub' not found
configure.ac:9:   'automake --add-missing' can install 'config.sub'
data/autostart/Makefile.am:1: error: ENABLE_SYSTEMTRAY does not appear in AM_CONDITIONAL
data/autostart/Makefile.am:4: error: ENABLE_INDICATOR does not appear in AM_CONDITIONAL
data/dbus/Makefile.am:1: error: ENABLE_DRIVER_KERNEL does not appear in AM_CONDITIONAL
data/icons/Makefile.am:2: error: ENABLE_ICONS_AWOKEN does not appear in AM_CONDITIONAL
data/icons/Makefile.am:5: error: ENABLE_ICONS_MONO does not appear in AM_CONDITIONAL
data/udev/Makefile.am:1: error: ENABLE_DRIVER_KERNEL does not appear in AM_CONDITIONAL
data/udev/Makefile.am:5: error: ENABLE_DRIVER_G19DIRECT does not appear in AM_CONDITIONAL
data/udev/Makefile.am:9: error: ENABLE_DRIVER_G15DIRECT does not appear in AM_CONDITIONAL
data/udev/Makefile.am:13: error: ENABLE_DRIVER_G930 does not appear in AM_CONDITIONAL
man/Makefile.am:1: error: ENABLE_SYSTEMTRAY does not appear in AM_CONDITIONAL
man/Makefile.am:5: error: ENABLE_INDICATOR does not appear in AM_CONDITIONAL
man/Makefile.am:9: error: ENABLE_DRIVER_KERNEL does not appear in AM_CONDITIONAL
src/Makefile.am:3: error: ENABLE_DRIVER_G19DIRECT does not appear in AM_CONDITIONAL
src/Makefile.am:7: error: ENABLE_PLUGIN_IMPULSE15 does not appear in AM_CONDITIONAL
src/Makefile.am:11: error: ENABLE_GNOME_SHELL_EXTENSION does not appear in AM_CONDITIONAL
src/gnome15/Makefile.am:3: error: Python sources seen but 'PYTHON' is undefined
src/gnome15/Makefile.am:3:   The usual way to define 'PYTHON' is to add 'AM_PATH_PYTHON'
src/gnome15/Makefile.am:3:   to 'configure.ac' and run 'aclocal' and 'autoconf' again.
src/gnome15/Makefile.am:3: error: required file './py-compile' not found
src/gnome15/Makefile.am:3:   'automake --add-missing' can install 'py-compile'
src/gnome15/drivers/Makefile.am:1: error: ENABLE_DRIVER_KERNEL does not appear in AM_CONDITIONAL
src/gnome15/drivers/Makefile.am:4: error: ENABLE_DRIVER_G19DIRECT does not appear in AM_CONDITIONAL
src/gnome15/drivers/Makefile.am:7: error: ENABLE_DRIVER_G15DIRECT does not appear in AM_CONDITIONAL
src/gnome15/drivers/Makefile.am:10: error: ENABLE_DRIVER_G930 does not appear in AM_CONDITIONAL
src/gnome15/drivers/Makefile.am:16: error: Python sources seen but 'PYTHON' is undefined
src/gnome15/drivers/Makefile.am:16:   The usual way to define 'PYTHON' is to add 'AM_PATH_PYTHON'
src/gnome15/drivers/Makefile.am:16:   to 'configure.ac' and run 'aclocal' and 'autoconf' again.
src/gnome15/util/Makefile.am:2: error: Python sources seen but 'PYTHON' is undefined
src/gnome15/util/Makefile.am:2:   The usual way to define 'PYTHON' is to add 'AM_PATH_PYTHON'
src/gnome15/util/Makefile.am:2:   to 'configure.ac' and run 'aclocal' and 'autoconf' again.
src/libimpulse/Makefile.am:6: error: 'pyexec_LTLIBRARIES' is used but 'pyexecdir' is undefined
src/libimpulse/Makefile.am:6:   The usual way to define 'pyexecdir' is to add 'AM_PATH_PYTHON'
src/libimpulse/Makefile.am:6:   to 'configure.ac' and run 'aclocal' and 'autoconf' again.
src/libimpulse/Makefile.am:1: error: Libtool library used but 'LIBTOOL' is undefined
src/libimpulse/Makefile.am:1:   The usual way to define 'LIBTOOL' is to add 'LT_INIT'
src/libimpulse/Makefile.am:1:   to 'configure.ac' and run 'aclocal' and 'autoconf' again.
src/libimpulse/Makefile.am:1:   If 'LT_INIT' is in 'configure.ac', make sure
src/libimpulse/Makefile.am:1:   its definition is in aclocal's search path.
src/libimpulse/Makefile.am: error: required file './depcomp' not found
src/libimpulse/Makefile.am:   'automake --add-missing' can install 'depcomp'
/usr/share/automake-1.15/am/depend2.am: error: am__fastdepCC does not appear in AM_CONDITIONAL
/usr/share/automake-1.15/am/depend2.am:   The usual way to define 'am__fastdepCC' is to add 'AC_PROG_CC'
/usr/share/automake-1.15/am/depend2.am:   to 'configure.ac' and run 'aclocal' and 'autoconf' again
/usr/share/automake-1.15/am/depend2.am: error: AMDEP does not appear in AM_CONDITIONAL
/usr/share/automake-1.15/am/depend2.am:   The usual way to define 'AMDEP' is to add one of the compiler tests
/usr/share/automake-1.15/am/depend2.am:     AC_PROG_CC, AC_PROG_CXX, AC_PROG_OBJC, AC_PROG_OBJCXX,
/usr/share/automake-1.15/am/depend2.am:     AM_PROG_AS, AM_PROG_GCJ, AM_PROG_UPC
/usr/share/automake-1.15/am/depend2.am:   to 'configure.ac' and run 'aclocal' and 'autoconf' again
src/libimpulse/Makefile.am:7: warning: variable 'impulse_la_SOURCES' is defined but no program or
src/libimpulse/Makefile.am:7: library has 'impulse_la' as canonical name (possible typo)
src/libimpulse/Makefile.am:10: warning: variable 'impulse_la_LIBADD' is defined but no program or
src/libimpulse/Makefile.am:10: library has 'impulse_la' as canonical name (possible typo)
src/libimpulse/Makefile.am:9: warning: variable 'impulse_la_LDFLAGS' is defined but no program or
src/libimpulse/Makefile.am:9: library has 'impulse_la' as canonical name (possible typo)
src/plugins/Makefile.am:1: error: ENABLE_PLUGIN_VOLUME does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:4: error: ENABLE_PLUGIN_RSS does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:7: error: ENABLE_PLUGIN_SYSMON does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:10: error: ENABLE_PLUGIN_PROCESSES does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:13: error: ENABLE_PLUGIN_CAL does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:16: error: ENABLE_PLUGIN_CAL_EVOLUTION does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:19: error: ENABLE_PLUGIN_LCDBIFF does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:22: error: ENABLE_PLUGIN_BACKGROUND does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:25: error: ENABLE_PLUGIN_CAIRO_CLOCK does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:28: error: ENABLE_PLUGIN_CLOCK does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:31: error: ENABLE_PLUGIN_FX does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:34: error: ENABLE_PLUGIN_MACRO_RECORDER does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:37: error: ENABLE_PLUGIN_MACROS does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:40: error: ENABLE_PLUGIN_PROFILES does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:43: error: ENABLE_PLUGIN_MOUNTS does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:46: error: ENABLE_PLUGIN_NOTIFY_LCD does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:49: error: ENABLE_PLUGIN_WEATHER does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:52: error: ENABLE_PLUGIN_WEATHER_NOAA does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:55: error: ENABLE_PLUGIN_WEATHER_YAHOO does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:58: error: ENABLE_PLUGIN_MPRIS does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:61: error: ENABLE_PLUGIN_MENU does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:64: error: ENABLE_PLUGIN_PANEL does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:67: error: ENABLE_PLUGIN_MEDIAPLAYER does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:70: error: ENABLE_PLUGIN_G15DAEMON_SERVER does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:73: error: ENABLE_PLUGIN_STOPWATCH does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:76: error: ENABLE_PLUGIN_SCREENSAVER does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:79: error: ENABLE_PLUGIN_INDICATOR_MESSAGES does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:82: error: ENABLE_PLUGIN_SENSE does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:85: error: ENABLE_PLUGIN_LCDSHOT does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:88: error: ENABLE_PLUGIN_TWEAK does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:91: error: ENABLE_PLUGIN_TAILS does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:94: error: ENABLE_PLUGIN_DISPLAY does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:97: error: ENABLE_PLUGIN_VOIP does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:100: error: ENABLE_PLUGIN_VOIP_TEAMSPEAK3 does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:103: error: ENABLE_PLUGIN_DEBUG does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:106: error: ENABLE_PLUGIN_TRAFFIC_STATS does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:109: error: ENABLE_PLUGIN_POMMODORO does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:112: error: ENABLE_PLUGIN_GAME_NEXUIZ does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:115: error: ENABLE_PLUGIN_BACKLIGHT does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:118: error: ENABLE_PLUGIN_NOTIFY_LCD2 does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:121: error: ENABLE_PLUGIN_NM does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:124: error: ENABLE_PLUGIN_LENS does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:127: error: ENABLE_PLUGIN_WEBKIT_BROWSER does not appear in AM_CONDITIONAL
src/plugins/Makefile.am:130: error: ENABLE_PLUGIN_IMPULSE15 does not appear in AM_CONDITIONAL
src/pylibg19/g19/Makefile.am:2: error: Python sources seen but 'PYTHON' is undefined
src/pylibg19/g19/Makefile.am:2:   The usual way to define 'PYTHON' is to add 'AM_PATH_PYTHON'
src/pylibg19/g19/Makefile.am:2:   to 'configure.ac' and run 'aclocal' and 'autoconf' again.
src/scripts/Makefile.am:2: error: ENABLE_SYSTEMTRAY does not appear in AM_CONDITIONAL
src/scripts/Makefile.am:6: error: ENABLE_INDICATOR does not appear in AM_CONDITIONAL
src/scripts/Makefile.am:10: error: ENABLE_DRIVER_KERNEL does not appear in AM_CONDITIONAL

wie weet weet Sillynder of iemand anders de oorzaak en nog belangrijker de oplossing

sorie voor de schrijffouten maar ik heb deceleksie.

ik gebruik debian linux met kernel 2.6.686