1

Onderwerp: Updaten lukt niet

Ik probeer mijn desktop te updaten maar dat lukt niet
Wat gaat er fout en wat doe ik er aan?

# root@koot:~# apt-get upgrade --dry-run
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
snapd : Depends: snap-confine (= 2.22.3) but it is not installed
E: Unmet dependencies. Try using -f.
root@koot:~# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  snapd
The following packages will be upgraded:
  snapd
1 upgraded, 0 newly installed, 0 to remove and 374 not upgraded.
2 not fully installed or removed.
Need to get 13,9 MB of archives.
After this operation, 15,8 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://nl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 snapd amd64 2.38 [13,9 MB]
Fetched 13,9 MB in 8s (1719 kB/s)                                                                                                                         
(Reading database ... 282202 files and directories currently installed.)
Preparing to unpack .../archives/snapd_2.38_amd64.deb ...
Warning: Stopping snapd.service, but it can still be activated by:
  snapd.socket
Failed to stop snapd.refresh.timer: Unit snapd.refresh.timer not loaded.
dpkg: warning: subprocess old pre-removal script returned error exit status 5
dpkg: trying script from the new package instead ...
Failed to stop snapd.failure.service: Unit snapd.failure.service not loaded.
Failed to stop snapd.seeded.service: Unit snapd.seeded.service not loaded.
dpkg: error processing archive /var/cache/apt/archives/snapd_2.38_amd64.deb (--unpack):
subprocess new pre-removal script returned error exit status 5
/usr/bin/deb-systemd-helper: error: unable to read snapd.refresh.timer
Failed to get unit file state for snapd.refresh.timer: No such file or directory
snapd.refresh.timer is a disabled or a static unit, not starting it.
Errors were encountered while processing:
/var/cache/apt/archives/snapd_2.38_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@koot:~# apt-get upgrade --dry-run
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
snapd : Depends: snap-confine (= 2.22.3) but it is not installed
E: Unmet dependencies. Try using -f.
root@koot:~# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  snapd
The following packages will be upgraded:
  snapd
1 upgraded, 0 newly installed, 0 to remove and 374 not upgraded.
2 not fully installed or removed.
Need to get 0 B/13,9 MB of archives.
After this operation, 15,8 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 282202 files and directories currently installed.)
Preparing to unpack .../archives/snapd_2.38_amd64.deb ...
Warning: Stopping snapd.service, but it can still be activated by:
  snapd.socket
Failed to stop snapd.refresh.timer: Unit snapd.refresh.timer not loaded.
dpkg: warning: subprocess old pre-removal script returned error exit status 5
dpkg: trying script from the new package instead ...
Failed to stop snapd.failure.service: Unit snapd.failure.service not loaded.
Failed to stop snapd.seeded.service: Unit snapd.seeded.service not loaded.
dpkg: error processing archive /var/cache/apt/archives/snapd_2.38_amd64.deb (--unpack):
subprocess new pre-removal script returned error exit status 5
/usr/bin/deb-systemd-helper: error: unable to read snapd.refresh.timer
Failed to get unit file state for snapd.refresh.timer: No such file or directory
snapd.refresh.timer is a disabled or a static unit, not starting it.
Errors were encountered while processing:
/var/cache/apt/archives/snapd_2.38_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Old programmers never die: they just jump to a new address
Kubuntu 16.02 LTS, Compaq CQ61 met Linux Mint 18, een Galaxy Tab 10.1 met Android Ice Cream en een Raspberry PI met raspian
http://www.volkerskrant.nl

2

Re: Updaten lukt niet

Wat moet ik met snapd? Heb ik het nodig? Ik kan nu firefox niet upgraden vanwege problemen met snapd.

Old programmers never die: they just jump to a new address
Kubuntu 16.02 LTS, Compaq CQ61 met Linux Mint 18, een Galaxy Tab 10.1 met Android Ice Cream en een Raspberry PI met raspian
http://www.volkerskrant.nl

Re: Updaten lukt niet

Tja, met DNF of Yum is dat makkelijker, maar hier de eerste google hit: https://askubuntu.com/questions/49578/g … -using-apt

ACAB: All computers are broken. https://medium.com/message/everything-i … e5f33a24e1 "I've decided that you need gray hair and hemorrhoids to be a consultant.
The gray hair makes you look distinguished & the hemorrhoids make you look concerned."

4

Re: Updaten lukt niet

Als ik op openSUSE een probleem heb met de automatisch update, dan open ik yast.

Dan zoek ik het probleem pakket op, en update het daar. Dit omdat yast, veel duidelijker aangeeft, waarom er iets niet lukt, en ook opties geeft om het op te lossen.

Computer games don't affect kids.  I mean if computer games had affected us as kids, we would all be running around in a darkened room, munching pills and listen to repetitive music.

5

Re: Updaten lukt niet

Moet je yast wel kunnen openen. Bij mij lukte dat laatst een paar keer niet. Na invoeren wachtwoord gebeurde er niets.
Inmiddels heeft het probleem zich vanzelf weer opgelost lijkt wel, want de boel loopt weer.

Open Suse 13.2
KDE 4.14.9
Linux 3.16.7-24

6

Re: Updaten lukt niet

Zypper kan ook

Help mee om KDE 5 in het Nederlands te vertalen!!