USB monitor (Samsung LD220) DisplayLink

Vragen over en antwoorden op problemen met je desktop
Gebruikersavatar
robert
Berichten: 51
Lid geworden op: zo jan 19, 2020 11:02 am

USB monitor (Samsung LD220) DisplayLink

Bericht door robert »

Ik probeer m'n USB monitor aan de praat te krijgen, dmesg zegt dat het een displaylink apparaat is en dat ik evdi nodig heb.

Code: Selecteer alles

[64843.178905] usb 2-9.2: New USB device found, idVendor=17e9, idProduct=0100, bcdDevice= 0.15
[64843.178910] usb 2-9.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[64843.178914] usb 2-9.2: Product: Samsung SMD220SU
[64843.178916] usb 2-9.2: Manufacturer: DisplayLink
[64843.178919] usb 2-9.2: SerialNumber: HMBS40131000000
[64843.183936] udlfb 2-9.2:1.0: vendor descriptor length: 27 data: 1b 5f 01 00 19 05 00 01 03 00 04
[64843.183942] udlfb 2-9.2:1.0: DL chip limited to -17152 pixel modes
[64843.269886] usb 2-9.2: fb1 is DisplayLink USB device (1920x1080, 8104K framebuffer memory)

Apt zegt daarop het volgende:

Code: Selecteer alles

The following NEW packages will be installed:
  evdi-dkms libevdi0
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 34.5 kB of archives.
After this operation, 170 kB of additional disk space will be used.
Get:1 http://ftp.nluug.nl/debian bullseye/main amd64 evdi-dkms all 1.6.4+dfsg-1 [25.4 kB]
Get:2 http://ftp.nluug.nl/debian bullseye/main amd64 libevdi0 amd64 1.6.4+dfsg-1 [9,104 B]
Fetched 34.5 kB in 1s (63.2 kB/s)   
Selecting previously unselected package evdi-dkms.
(Reading database ... 184870 files and directories currently installed.)
Preparing to unpack .../evdi-dkms_1.6.4+dfsg-1_all.deb ...
Unpacking evdi-dkms (1.6.4+dfsg-1) ...
Selecting previously unselected package libevdi0.
Preparing to unpack .../libevdi0_1.6.4+dfsg-1_amd64.deb ...
Unpacking libevdi0 (1.6.4+dfsg-1) ...
Setting up evdi-dkms (1.6.4+dfsg-1) ...
Loading new evdi-1.6.4+dfsg DKMS files...
Building for 5.4.0-3-amd64
Building initial module for 5.4.0-3-amd64
Error! Bad return status for module build on kernel: 5.4.0-3-amd64 (x86_64)
Consult /var/lib/dkms/evdi/1.6.4+dfsg/build/make.log for more information.
dpkg: error processing package evdi-dkms (--configure):
 installed evdi-dkms package post-installation script subprocess returned error exit status 10
Setting up libevdi0 (1.6.4+dfsg-1) ...
Processing triggers for libc-bin (2.29-9) ...
Errors were encountered while processing:
 evdi-dkms
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ik lees hier https://github.com/DisplayLink/evdi/issues/172 Wel een hoop over patches, maar die zitten dan niet in de kernel? Hoe krijg ik die meuk 1 geinstalleerd, dat zal nog wel lukken als dat zoals vroeger gaat, maar hoe krijg ik 2 apt weer blij? Of kan ik het probleem in apt oplossen en zo twee vliegen in een klap?

Plaats reactie